Mühendislik ve Mimarlık Fakültesi


 Popüler NPM Paketi, Ukrayna İstilasını Protesto Etmek İçin Rusya ve Beyaz Rusya Sistemlerini Silmek Üzere Güncellendi


Popüler "node-ipc" NPM paketinin arkasındaki geliştirici, kasıtlı bir sabotaj olarak, Rusya'nın Ukrayna'yı işgalini kınamak için kurcalanmış yeni bir sürüm gönderdi ve açık kaynak ve yazılım tedarik zincirindeki güvenlikle ilgili endişeleri artırdı.
Kütüphanenin 10.1.1 ve 10.1.2 sürümlerini etkileyen, sağlayıcısı RIAEvangelist tarafından yapılan değişiklikler, kullanıcıları Rusya veya Beyaz Rusya'da bulunan IP adreslerine hedefleyerek ve rastgele dosya içeriklerini silerek ve bir kalp emojisi ile değiştirerek istenmeyen davranışlara neden oldu.
 
Node-ipc, Linux, macOS ve Windows desteği ile yerel ve uzak süreçler arası iletişim (IPC) için kullanılan önde gelen bir düğüm modülüdür. Haftalık 1,1 milyondan fazla indirmeye sahiptir.
 
Synk araştırmacısı Liran Tal bir analizde, "Bu NPM paketinin çağrılacağı herhangi bir sistem için, Rusya veya Beyaz Rusya'nın coğrafi konumuyla eşleşirse, çok açık bir kötüye kullanım ve kritik bir tedarik zinciri güvenlik olayı meydana gelecektir." Dedi.
 
Soruna CVE-2022-23812 tanımlayıcısı atanmıştır ve CVSS güvenlik açığı puanlama sisteminde 10 üzerinden 9,8 olarak derecelendirilmiştir. Kötü amaçlı kod değişiklikleri 7 Mart'ta (sürüm 10.1.1) yayınlandı ve aynı gün 10 saat sonra ikinci bir güncelleme yapıldı (sürüm 10.1.1).
 
İlginç bir şekilde, yıkıcı değişiklikler sürüm 10.1 ile kütüphaneden kaldırılmış olsa da, dört saatten daha kısa bir süre sonra (sürüm 11.0.0) büyük bir güncelleme gönderildi ve bu güncelleme, "peacenotwar" adlı başka bir bağımlılığı içe aktardı ve bu da RIAEvangelist tarafından bir tür olarak yayınlandı. "Rusya'nın saldırganlığına karşı şiddet içermeyen protesto."

Kaynak:https://thehackernews.com/2022/03/popular-npm-package-updated-to-wipe.html

Haberler

Tüm Haberler